Lamobo Openwrt image
OpenWrt firmware for BPI-R1 is updated, it support by Lamobo.
This firmware is built based on the OpenWrt master branch r42830.
Q&A
  • I am a new BPI-R1 user, how to use this firmware? 1. For a new user, we recommend to use the ready configured firmware. please download it from forum download page: http://elastos.org/elorg_common/Lamobo-R1/2015-01-12/openwrt-sunxi-Lamobo-R1-sdcard-vfat-ext4.img 2. BPI-R1 accepts TF-card. Make sure your TF-card is bigger than 512MB. Using below command to generate a bootable TD-card: $ sudo dd if=openwrt-sunxi-BPI-R1-sdcard-vfat-ext4-configured.img of=/dev/sdX bs=1MB
    1. 1.
      Notes for the ready configured firmware:
  • If I want to use the original firmware, what can I do?
    1. 1.
      The original firmware is built directly from source code. It almost does not install software, except OpenWrt base software. Please download it from:elastos.org/elorg_common/Lamobo-R1/2015-...sdcard-vfat-ext4.img.
    2. 2.
      Prepare a TTL thread for to connent OpenWrt bash terminal.
    3. 3.
      Connect to OpenWrt terminal throught TTL thread, modify OpenWrt packages source. All Of OpenWrt packages is released on:
      1
      elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages. You can change opkg.conf(/etc/opkgopkg.conf) content to below:
      2
      src/gz chaos_calmer_base http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/base
      3
      src/gz chaos_calmer_luci http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/luci
      4
      src/gz chaos_calmer_management http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/management
      5
      src/gz chaos_calmer_packages http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/packages
      6
      src/gz chaos_calmer_routing http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/routing
      7
      src/gz chaos_calmer_telephony http://elastos.org/elorg_common/Lamobo-R1/2014-01-12/packages/telephony
      Copied!
      And then, update opkg database: $ opkg update
    4. 4.
      Install OpenWrt packages. The below packages are needed:
      1
      $ opkg install kmod-b53
      2
      $ opkg install kmod-rtl*
      3
      $ opkg install hostapd
      4
      $ opkg install wpa-supplicant
      5
      $ opkg install luci-proto-ppp
      6
      $ opkg install ppp-mod-pptp
      7
      $ opkg install luci
      8
      $ opkg install luci-theme-bootstrap
      Copied!
      Full package list please refer: kingone.elastos.org/2015/01/13/lamobo-r1-package-list/
    5. 5.
      Modify the network config.Append below text to “/etc/config/network”:
1
config switch ‘eth0′
2
option enable ’1′
3
option enable_vlan ’1′
4
option reset ’1′
5
6
config interface ‘lan’
7
option proto ‘static’
8
option ipaddr ’10.0.1.1′
9
option netmask ’255.255.255.0′
10
option defaultroute ’0′
11
option peerdns ’0′
12
option nat ’1′
13
option ifname ‘eth0.1′
14
option type ‘bridge’
15
16
config switch_vlan
17
option device ‘eth0′
18
option ports ’0 1 2 4 8t’
19
option vlan ’1′
20
21
config interface ‘wan’
22
option ifname ‘eth0.2′
23
option proto ‘dhcp’
24
25
config switch_vlan
26
option device ‘eth0′
27
option vlan ’2′
28
option ports ’3 8t’
Copied!
start router web server:
1
$ /etc/init.d/uhttpd start
2
$ /etc/init.d/uhttpd enable
Copied!
That’s all. Good luck!
forum discuss link:
Wiki link:
Copy link